月別アーカイブ: 2017年10月

Apache httpd 2.4.29 + HTTP/2 + Brotli インストールメモ

2017年10月23日 Apache httpd2.4.29 がリリースされました。バージョン2.4.28のリリースからわずか18日でのリリースになります。ここ最近 Apache httpd 2.4系は、新機能の追加や脆弱性への対応を積極的に行なっているため(利用者にとってはありがたいことです)アップデート情報から目がはなせませんね。さっそく、CentOS7.4 (1708) に HTTP/2 と Brotli に対応した Apache httpd 2.4.29 をインストールする手順をまとめてみました。 ▷続きを読む

Apache の ACMEモジュールで Let's Encrypt 証明書を取得してみた

ACME は、SSL/TLSサーバー証明書の発行や管理などを自動で行うための仕組みです。Apache httpd ではこの ACME をサポートする mod_md(Managed Domain)というモジュールの開発が進められていて、将来 Apache httpd 2.4.x の安定版へのリリースが計画されています。そこで今回は一足先に、Apache の ACMEモジュール mod_md を使った Let's Encrypt 証明書の取得を試してみました。 ▷続きを読む

HTTP/2 に対応した Apache を yum でインストール

これまで HTTP/2 に対応した Apache httpd をインストールするには、関連するライブラリを含めソースからコンパイルしなければならないため、なかなかの手間がかかっていました。しかし CentOS7.4 (1708) から OpenSSL1.0.2 がサポートされたことにより、CentOSコミュニティ承認済みの IUSリポジトリから yum で簡単にインストールできるようになりました。そこで今回は、IUSリポジトリを使って HTTP/2 に対応した Apache httpd をインストールする手順をまとめてみました。 ▷続きを読む

平成29年度秋期 情報処理安全確保支援士試験 午後の解答メモ

昨日(2017年10月15日)IPAが実施している情報処理安全確保支援士試験を受けてきました。午前試験の公式解答例は即日公開されますが、午後試験の解答例の公開は2ヶ月先になるので試験後に正解が あーでもない こーでもない と議論するのがこの試験の楽しいところでもあり、合格しているか不安で悶々とするところでもあります(^^;) そこで今回は、午後1試験の問1と問3、午後2試験の問1で自分が書いた解答をメモしておきました。 ▷続きを読む